Reply
Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Old 10-17-2020, 08:37 PM   #1
DirkDiggler
Eight Point
 
Join Date: Jun 2012
Location: Melissa, Tx
Hunt In: Collin County
Default Ford 5.0 trucks

Anyone have a 4x4 F-150 with the 5.0?

Do you like it?

Looking at one at a dealership and was hoping for some feedback on this engine
DirkDiggler is offline   Reply With Quote Back To The Top
Old 10-17-2020, 08:40 PM   #2
futureagg
Eight Point
 
futureagg's Avatar
 
Join Date: Dec 2010
Location: Katy
Hunt In: Crockett
Default

I have a 2018 model with 56k miles. Truck has been good. Now make sure to test drive it a few times and make sure you are okay with having to turn the auto start stop feature off every time you crank it up.

No engine issues with the truck so far.


Sent from my iPhone using Tapatalk
futureagg is online now   Reply With Quote Back To The Top
Old 10-17-2020, 08:41 PM   #3
JayB
Ten Point
 
JayB's Avatar
 
Join Date: Oct 2006
Location: Rowlett
Hunt In: Cass County
Default

Mine is not 4 x 4 but the 5.0 is awesome. Does what I want when I want it too. Recently averaged 24 mpg on a trip to New Jersey and back.

.....and God Bless America.
JayB is offline   Reply With Quote Back To The Top
Old 10-17-2020, 08:42 PM   #4
Antlers86
Pope & Young
 
Antlers86's Avatar
 
Join Date: Oct 2011
Location: Athens
Hunt In: Jack and Henderson Counties
Default

Have a 2014 Model and like it. No issues in 110k miles
Antlers86 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 08:49 PM   #5
boy wonder
Ten Point
 
Join Date: Oct 2006
Location: Brock
Hunt In: The river
Default

My 2018 has 65k on it, no issues.
boy wonder is offline   Reply With Quote Back To The Top
Old 10-17-2020, 08:51 PM   #6
maxbrown
Nubbin' Buck
 
Join Date: Nov 2015
Location: Fort Worth, Texas
Hunt In: Wise County, Montana, Arkansas
Default

I’ve got a 2011 lariat 5.0 4x4 with 214,000 miles. Just drove from Texas to Montana and back for an elk hunt. No major problems so far
maxbrown is offline   Reply With Quote Back To The Top
Old 10-17-2020, 08:53 PM   #7
Drycreek3189
Pope & Young
 
Drycreek3189's Avatar
 
Join Date: Jun 2013
Location: Troup
Hunt In: Cherokee, Rusk, Trinity Counties
Default

Quote:
Originally Posted by futureagg View Post
I have a 2018 model with 56k miles. Truck has been good. Now make sure to test drive it a few times and make sure you are okay with having to turn the auto start stop feature off every time you crank it up.

No engine issues with the truck so far.


Sent from my iPhone using Tapatalk
This exactly, right down to the miles and year model. It will get 22 mph on the interstate in Eco mode. The auto stop is just a huge pain in the azz.
Drycreek3189 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 08:53 PM   #8
Grulla
Ten Point
 
Grulla's Avatar
 
Join Date: Oct 2013
Location: Yoakum tx
Hunt In: Guadalupe River
Default

Had a 16 model 5 liter and no problems until it got about 130,000 and the number 8 cylinder would misfire . Apparently it’s a common issue with that motor according to the forums . Great truck otherwise .
Grulla is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:02 PM   #9
ken800
Six Point
 
Join Date: Nov 2019
Location: Liberty Hill
Hunt In: Lampasas
Default

56K on a 17. SOLID motor.
ken800 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:09 PM   #10
txpitdog
Pope & Young
 
txpitdog's Avatar
 
Join Date: Dec 2006
Location: Kingwood
Hunt In: Fairfield
Default

Had a 2018 with the 5.0. Engine had a low knock, dash had persistent electrical issues. Really wanted to like the truck but ditched it due to the ongoing problems.


Sent from my iPad using Tapatalk
txpitdog is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:10 PM   #11
Smart
Pope & Young
 
Smart's Avatar
 
Join Date: Oct 2006
Location: Denton, TX
Hunt In: Tom Green County
Default

Quote:
Originally Posted by futureagg View Post
I have a 2018 model with 56k miles. Truck has been good. Now make sure to test drive it a few times and make sure you are okay with having to turn the auto start stop feature off every time you crank it up.

No engine issues with the truck so far.


Sent from my iPhone using Tapatalk
Quote:
Originally Posted by Drycreek3189 View Post
This exactly, right down to the miles and year model. It will get 22 mph on the interstate in Eco mode. The auto stop is just a huge pain in the azz.



Don't they make several fixes for that auto start/stop including something as simple as plugging in a trailer plug? I have two folks on my lease that don't have to deal with that any more
Smart is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:33 PM   #12
bps3040
Pope & Young
 
bps3040's Avatar
 
Join Date: Nov 2006
Location: Spring,Texas
Hunt In: West Texas, Dryden area, Forestville, Canada
Default Ford 5.0 trucks

Quote:
Originally Posted by maxbrown View Post
Iíve got a 2011 lariat 5.0 4x4 with 214,000 miles. Just drove from Texas to Montana and back for an elk hunt. No major problems so far

I had same year. Just traded it in with 218,000 miles on it. Loved the truck


Sent from my iPhone using Tapatalk
bps3040 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:36 PM   #13
MLank
Ten Point
 
MLank's Avatar
 
Join Date: Feb 2009
Location: Dallas
Default

Quote:
Originally Posted by futureagg View Post
I have a 2018 model with 56k miles. Truck has been good. Now make sure to test drive it a few times and make sure you are okay with having to turn the auto start stop feature off every time you crank it up.

No engine issues with the truck so far.


Sent from my iPhone using Tapatalk
I de activated mine. Pulled one chord. If I was to tow something, I’d plug the wire back in.

Also make sure you are familiar with the 10 speed trans and the clickity clack it has at low speeds when you slightly hit the gas pedal and then let off. Additionally, the whistling sound as it changes gears. Drive with the windows open.
MLank is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:37 PM   #14
JB_Archery
Four Point
 
JB_Archery's Avatar
 
Join Date: Dec 2017
Location: Cypress
Hunt In: Texas, New Mexico & Arizona
Default

Yeah that motor is bulletproof
JB_Archery is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:45 PM   #15
Drycreek3189
Pope & Young
 
Drycreek3189's Avatar
 
Join Date: Jun 2013
Location: Troup
Hunt In: Cherokee, Rusk, Trinity Counties
Default

Quote:
Originally Posted by Smart View Post
Don't they make several fixes for that auto start/stop including something as simple as plugging in a trailer plug? I have two folks on my lease that don't have to deal with that any more
Yeah, Iíve wondered if that would work, just too **** lazy or forgetful to try it. Iíve about got myself trained to punch it off as soon as I start up now.
Drycreek3189 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:45 PM   #16
futureagg
Eight Point
 
futureagg's Avatar
 
Join Date: Dec 2010
Location: Katy
Hunt In: Crockett
Default

Quote:
Originally Posted by Smart View Post
Don't they make several fixes for that auto start/stop including something as simple as plugging in a trailer plug? I have two folks on my lease that don't have to deal with that any more

But then your truck is constantly bugging you that you have a trailer connected I know itís minor things. Just wish there was a permanent fix without using a jumper cable, trailer plug, or unplugging wires under the dash.


Sent from my iPhone using Tapatalk
futureagg is online now   Reply With Quote Back To The Top
Old 10-17-2020, 09:49 PM   #17
bigt6450
Six Point
 
bigt6450's Avatar
 
Join Date: Oct 2016
Location: Pflugerville
Default

Have a 5.0 in a 2wd on a '17. Only complaints are that I don't have the 10 speed transmission, and believe it or not I wish I had the auto start/stop. I know a lot of people hate it, but to me it didn't bother me once you learn how to work the brake pedal (had it on a couple loaners I've had).

I work in Austin, so prior to COVID I was in a lot of start/stop traffic, and the start/stop feature really did seem to save 1/2 MPG a tank.
bigt6450 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:51 PM   #18
BigL
Pope & Young
 
BigL's Avatar
 
Join Date: Oct 2006
Location: Round Rock
Hunt In: San Saba
Default

I have a 2011 XLT 4x4 with over 200,000 miles. Would buy it again. Pulled my 32' travel trailer to Florida and back a few months ago. Have pulled it out of state many trips. Great engine.
BigL is online now   Reply With Quote Back To The Top
Old 10-17-2020, 09:52 PM   #19
MLank
Ten Point
 
MLank's Avatar
 
Join Date: Feb 2009
Location: Dallas
Default

Quote:
Originally Posted by futureagg View Post
But then your truck is constantly bugging you that you have a trailer connected I know itís minor things. Just wish there was a permanent fix without using a jumper cable, trailer plug, or unplugging wires under the dash.


Sent from my iPhone using Tapatalk
I unplugged a wire and it bugs me zero times.
MLank is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:54 PM   #20
basskicker24
Ten Point
 
basskicker24's Avatar
 
Join Date: Oct 2011
Location: San Antonio
Hunt In: Guadalupe county/ Ozona
Default

I had a 2014. I loved it. No issues. I had to to trade it for a 2500 due to my trailer I pull. Only reason I traded. I miss it.


Sent from my iPhone using Tapatalk
basskicker24 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:56 PM   #21
Artos
Pope & Young
 
Artos's Avatar
 
Join Date: Nov 2007
Location: Deep South TX
Hunt In: Deep South TX
Default

Had an 18 company I put 100k in 14mos that ran flawless...the auto button is stupid but becomes auto before the seatbelt is reached for.

5.0 is the best for longevity
Artos is offline   Reply With Quote Back To The Top
Old 10-17-2020, 09:57 PM   #22
firemanjj82
Ten Point
 
firemanjj82's Avatar
 
Join Date: Aug 2009
Default

Have a 2014 4x4 5.0. I really did my homework before deciding against the 3.5, and what it came down to was build quality, longevity, and the ability to work on my own motor if necessary. I've got 93,*** on it now and only issue I've had has been with the recirc door on the AC breaking off the hinge, along with a transmission bump, but that's pretty much across the board on my gen f150. Completed spark plugs last month and will be driving it to South Dakota next month. Took that drive last year and averaged 22 mpg loaded.

And I love the 36 gallon tank.

You take care of it and it'll take care of you.

Sent from my SM-G960U using Tapatalk
firemanjj82 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 10:03 PM   #23
txtrophy85
Ten Point
 
txtrophy85's Avatar
 
Join Date: Feb 2011
Location: Boerne
Hunt In: All over the World
Default

I had a 2011 FX4 crew cab with the 5.0. It was truly a great truck. Had a leveling kit and 35’s on it and would get around 15 mpg.

I sold it with 173k on the ODO and it drove like it was pretty much new.
txtrophy85 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 10:08 PM   #24
brains
Spike
 
Join Date: Jan 2015
Default

I have a 2018 as well with 65000 miles. Love it. Hate the auto kill too, but I guess I’m used to it. Average about 18mpg. Stock.
brains is offline   Reply With Quote Back To The Top
Old 10-17-2020, 10:10 PM   #25
futureagg
Eight Point
 
futureagg's Avatar
 
Join Date: Dec 2010
Location: Katy
Hunt In: Crockett
Default

Quote:
Originally Posted by MLank View Post

I unplugged a wire and it bugs me zero times.

What wire? Any issues when pulling a trailer etc?


Sent from my iPhone using Tapatalk
futureagg is online now   Reply With Quote Back To The Top
Old 10-17-2020, 10:20 PM   #26
FireNguns
Pope & Young
 
FireNguns's Avatar
 
Join Date: Apr 2013
Location: Lindsay
Hunt In: Grayson, Montgue, Wise
Default

2015 fx4 with 83k and no issues.
FireNguns is offline   Reply With Quote Back To The Top
Old 10-17-2020, 10:25 PM   #27
Grand Passage
Eight Point
 
Grand Passage's Avatar
 
Join Date: Dec 2013
Location: Fair Oaks
Hunt In: Hill Country & South TX
Default

Quote:
Originally Posted by MLank View Post



I unplugged a wire and it bugs me zero times.


This
Grand Passage is offline   Reply With Quote Back To The Top
Old 10-17-2020, 10:33 PM   #28
MLank
Ten Point
 
MLank's Avatar
 
Join Date: Feb 2009
Location: Dallas
Default

Quote:
Originally Posted by futureagg View Post
What wire? Any issues when pulling a trailer etc?


Sent from my iPhone using Tapatalk
If/when you pull a trailer, plug the wire back in.

As for which wire, you will have to do some YouTube researching and decide what’s best for you.

Benefits > inconvenience
MLank is offline   Reply With Quote Back To The Top
Old 10-17-2020, 10:37 PM   #29
BW412
Eight Point
 
BW412's Avatar
 
Join Date: Jan 2009
Default

I have a 2013 FX4 with 87000 mines. No issues
BW412 is offline   Reply With Quote Back To The Top
Old 10-17-2020, 11:37 PM   #30
Mexico
Pope & Young
 
Mexico's Avatar
 
Join Date: Jun 2012
Location: Clear Lake Tx
Hunt In: Old Mexico, Centerville Tx
Default

Love mine!
Mexico is offline   Reply With Quote Back To The Top
Old 10-18-2020, 01:30 AM   #31
Smoore12
Four Point
 
Join Date: Jul 2020
Default

2017 with 34k. Been incredible
Smoore12 is offline   Reply With Quote Back To The Top
Old 10-18-2020, 06:34 AM   #32
DedDuk
Four Point
 
Join Date: Aug 2018
Location: Onalaska
Hunt In: East and West TX
Default

2019 FX4 with 5.0. Only has about 12k miles but no issues. I push the auto stop when I put it in gear. Not a big deal. I may look into pulling the wire since I use my diesel when pulling a trailer.
DedDuk is offline   Reply With Quote Back To The Top
Old 10-18-2020, 07:15 AM   #33
stryker93
Ten Point
 
stryker93's Avatar
 
Join Date: Feb 2007
Location: Seguin, TX
Hunt In: Guadalupe & Frio Cty
Default

I have a 2019 with 60000 on it. It was just in the shop for something to do with the cam sensor and the recirculate door. About 1k worth of work but under warranty. It had a really rough idle and died once before the check engine light came on. Ford wouldnít do anything until check engine came on and stayed on.
stryker93 is offline   Reply With Quote Back To The Top
Old 10-18-2020, 07:20 AM   #34
Daddypants
Six Point
 
Join Date: Dec 2012
Default

2017 4x4 w/ 5.0. Great engine. Great truck. If you are actually going to use it for hauling and towing, it needs some stiffer springs or bags in the rear. They are pretty soft. Other than that, they are great trucks.
Daddypants is offline   Reply With Quote Back To The Top
Old 10-18-2020, 07:54 AM   #35
Bigfootwolff
Eight Point
 
Bigfootwolff's Avatar
 
Join Date: May 2010
Location: Katy,Texas
Hunt In: Anderson County, Colorado County
Default

I have a 2016 F150 5.0 and The engine has been flawless. It has 55,000 miles and still idles so smooth there are times I think the engine is off.
Bigfootwolff is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:07 AM   #36
gunnut 99
Ten Point
 
gunnut 99's Avatar
 
Join Date: Nov 2010
Location: Argyle
Hunt In: Anderson County,Parker County and Colorado
Default

Auto Start Stop Delete/Disable/Eliminator on amazon for $40

But there are several different ones out there.

https://www.amazon.com/Auto-Start-De...a-785316295841
gunnut 99 is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:34 AM   #37
mechhead
Ten Point
 
mechhead's Avatar
 
Join Date: Aug 2012
Location: East Texas
Default

Quote:
Originally Posted by txpitdog View Post
Had a 2018 with the 5.0. Engine had a low knock, dash had persistent electrical issues. Really wanted to like the truck but ditched it due to the ongoing problems.


Sent from my iPad using Tapatalk


Same...low engine knock, oil consumption, radio / gps/ screen would black out. Along with the warped dash. Kept for just over a year.
mechhead is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:43 AM   #38
Maxlab
Ten Point
 
Maxlab's Avatar
 
Join Date: Jul 2010
Location: San Antonio
Hunt In: Jimwells/Gonzalez
Default

It’s a solid engine, and can be easily modded for more power.
Maxlab is offline   Reply With Quote Back To The Top
Old 10-18-2020, 04:58 PM   #39
DirkDiggler
Eight Point
 
Join Date: Jun 2012
Location: Melissa, Tx
Hunt In: Collin County
Default

Thanks for all the feedback fellas. This makes it easy
DirkDiggler is offline   Reply With Quote Back To The Top
Old 10-18-2020, 05:31 PM   #40
Grant2
Ten Point
 
Grant2's Avatar
 
Join Date: Sep 2012
Hunt In: Sonroa, Comfort
Default

Do yourself a favor and keep looking at other brands just my 2 cents worth.
Grant2 is offline   Reply With Quote Back To The Top
Old 10-18-2020, 07:32 PM   #41
SaltwaterSlick
Pope & Young
 
Join Date: Oct 2006
Default

I have an '18 with 120,000+ miles on it. 4 X 4 King ranch trim package... I also have the 6 1/2 foot bed and large gas tank... Normal driving, I get 650 miles to a tank of gas. Best half ton I ever had so far... Had an eco Boost before that in a truck exactly like it. I'd order another one tomorrow if I needed a new truck...
SaltwaterSlick is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:26 PM   #42
BowSlayer
Pope & Young
 
BowSlayer's Avatar
 
Join Date: Aug 2011
Location: Troup
Hunt In: Smith County
Default

2016 FX4 with 55,000 miles. At 44,000 miles my check engine light came on and truck was sluggish. Dealership ended up replacing the intake manifold under the power train warranty. Hasnít acted up since. I just pulled my 28í travel trailer to the lease yesterday. Got less than 8 mpg but I didnít cut it any slack. I also have level kit and larger than stock tires.


BowSlayer is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:29 PM   #43
Bama
Ten Point
 
Bama's Avatar
 
Join Date: Oct 2006
Location: Rowlett
Hunt In: Stovallcustomknives facebook
Default

I'm the shop foreman at a ford dealership I drive a 5.0 wouldn't want anything else.
Bama is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:32 PM   #44
150class
Pope & Young
 
150class's Avatar
 
Join Date: Oct 2008
Location: The Woodlands
Hunt In: Uvalde, Boerne
Default

Have a 2017 5.0 with 105k miles and no complaints. Need to replace a vacuum hose and the back up camera is staying on longer than it should but that’s obviously not motor related.

Boss has a 2017 5.0 with 125k and hates it. Having all sorts of idling issues the last 30-35k miles
150class is offline   Reply With Quote Back To The Top
Old 10-18-2020, 08:50 PM   #45
progolferv1
Ten Point
 
progolferv1's Avatar
 
Join Date: Dec 2014
Location: Frisco
Default

Quote:
Originally Posted by mechhead View Post
Same...low engine knock, oil consumption, radio / gps/ screen would black out. Along with the warped dash. Kept for just over a year.


Same here. 2018. 30k miles. been in the shop 6 times for a engine rattle which ford has issues a TSB for it. Now they are telling me is a normal engine noise. Hardly normal.
progolferv1 is offline   Reply With Quote Back To The Top
Old 10-18-2020, 09:10 PM   #46
Lonewolf
Six Point
 
Lonewolf's Avatar
 
Join Date: May 2007
Location: Mineral Wells Texas
Hunt In: Young and Palo Pinto counties
Default

I have a 2014 with 247,000 miles on it and it has been a great truck!
Lonewolf is offline   Reply With Quote Back To The Top
Old 10-18-2020, 09:27 PM   #47
Mudslinger
Pope & Young
 
Mudslinger's Avatar
 
Join Date: Oct 2006
Location: Rogers, TX
Hunt In: Kent Co., Stonewall Co., CO, Limpopo RSA
Default

2014 and no problems except for mice! Just went over 100,000 miles and runs like a top. Now my wife's vehicle!
Mudslinger is offline   Reply With Quote Back To The Top
Old 10-18-2020, 11:41 PM   #48
Rileym272
Four Point
 
Rileym272's Avatar
 
Join Date: Mar 2014
Location: Cypress
Hunt In: Schlunberg, we're ever I can
Default

Quote:
Originally Posted by maxbrown View Post
Iíve got a 2011 lariat 5.0 4x4 with 214,000 miles. Just drove from Texas to Montana and back for an elk hunt. No major problems so far
I also have a 2011 with 212 on the clock. It has been a good solid reliable truck, and has Had no major issues.
Rileym272 is offline   Reply With Quote Back To The Top
Old 10-19-2020, 05:30 AM   #49
sm351
Four Point
 
Join Date: Dec 2009
Location: Saginaw
Hunt In: Eden
Default

I have a 2013 still going with 295,000.
sm351 is offline   Reply With Quote Back To The Top
Old 10-19-2020, 09:59 AM   #50
jfk47
Ten Point
 
jfk47's Avatar
 
Join Date: Dec 2006
Location: San Antonio
Hunt In: Lavaca and Jackson counties
Default

I have a 2011 XLT with the 5.0 4x4. Just turned 200K. Not a single problem so far. Thought about upgrading several times, but can't make myself do it. I think this thing will run forever !!
jfk47 is offline   Reply With Quote Back To The Top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:00 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1999-2012, TexasBowhunter.com