Reply
Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Old 11-19-2019, 06:38 AM   #1
Leemo
Ten Point
 
Leemo's Avatar
 
Join Date: Jun 2008
Location: Bay City, Texas
Default F150...fuel problem..when filling

2016 F150, wifeís truck
When filling with gas, it shuts the pump off every gallon of gas, like itís full?
Pain in the butt, something is restricting the flow?
Leemo is offline   Reply With Quote Back To The Top
Old 11-19-2019, 06:50 AM   #2
tx_basser
Six Point
 
Join Date: Oct 2009
Location: Sachse, TX
Hunt In: Any place Public
Default

My 2015 does that and i have had to make sure the pump handle is straight and not use the highest delivery setting.
tx_basser is offline   Reply With Quote Back To The Top
Old 11-19-2019, 06:53 AM   #3
M16
Pope & Young
 
M16's Avatar
 
Join Date: Dec 2009
Hunt In: Colorado, LaSalle, ,Menard Counties
Default

Something probably wrong with the filler neck portion. Nothing that $500 won’t fix.
M16 is offline   Reply With Quote Back To The Top
Old 11-19-2019, 07:15 AM   #4
Bowtech38
Pope & Young
 
Bowtech38's Avatar
 
Join Date: Dec 2013
Location: Belton
Default

My 07 silverado does that also
Bowtech38 is offline   Reply With Quote Back To The Top
Old 11-19-2019, 07:31 AM   #5
cva34
Ten Point
 
Join Date: Sep 2016
Location: van vleck
Hunt In: LOOKING
Default

Its the Evap system with canister...on my chevy every time...Ford prob got similar system
cva34 is offline   Reply With Quote Back To The Top
Old 11-19-2019, 07:36 AM   #6
Texas Tracker
Pope & Young
 
Texas Tracker's Avatar
 
Join Date: Nov 2006
Location: Wimberley Texas/Hunt every place I can!
Default

My wife's Yukon XL dose that also. Sucks
Texas Tracker is offline   Reply With Quote Back To The Top
Old 11-19-2019, 07:36 AM   #7
sotol
Six Point
 
Join Date: Apr 2015
Default

Yep. I would go with the vent canister . Just another thing you get to spend some money on.

Sent from my LG-K550 using Tapatalk
sotol is offline   Reply With Quote Back To The Top
Old 11-19-2019, 08:34 AM   #8
az2tx
Pope & Young
 
az2tx's Avatar
 
Join Date: Dec 2007
Location: Boerne
Default

Do you always get gas at the same place for the most part? My 2015 F150 will do it too but only at a single pump at the station otherwise its probably the vent or vent hose
az2tx is offline   Reply With Quote Back To The Top
Old 11-19-2019, 08:46 AM   #9
WTucker
Ten Point
 
WTucker's Avatar
 
Join Date: Aug 2016
Location: Orangefield
Default

Almost all of our F250s at work did that. The vent canister gets plugged up from dust, mud, etc.
WTucker is online now   Reply With Quote Back To The Top
Old 11-19-2019, 08:50 AM   #10
KIETHSTONE
Ten Point
 
KIETHSTONE's Avatar
 
Join Date: Jan 2011
Location: Flint
Hunt In: Jack
Default

Where is the canister located?


Sent from my iPhone using Tapatalk
KIETHSTONE is offline   Reply With Quote Back To The Top
Old 11-19-2019, 08:53 AM   #11
Saltyag15
Ten Point
 
Saltyag15's Avatar
 
Join Date: Aug 2013
Location: Falls City
Hunt In: Karnes, La Salle, and Sutton Counties
Default

Quote:
Originally Posted by KIETHSTONE View Post
Where is the canister located?


Sent from my iPhone using Tapatalk
x2

My 06 F-150 has had that problem forever, and my 17 Silverado just started doing this about a month ago.
Saltyag15 is offline   Reply With Quote Back To The Top
Old 11-19-2019, 08:55 AM   #12
texan4ut
Ten Point
 
texan4ut's Avatar
 
Join Date: Jul 2014
Location: Round Rock, TX
Hunt In: Where I can, Terrell County
Default

My Chevy did that my Ford F150 only every once in a while. When I am at a pump that does that I have to pull the pump handle out a bit then not use the the fastest setting. If it is doing it at every single pump she goes to then I don't know what to tell you.
texan4ut is offline   Reply With Quote Back To The Top
Old 11-19-2019, 08:59 AM   #13
deerplanter
Ten Point
 
deerplanter's Avatar
 
Join Date: Nov 2007
Location: Beach City
Default

You can pull the evap canister off and wash it out. Look for a YouTube channel on your vehicle I did my 14 Silverado and it helped some.
deerplanter is offline   Reply With Quote Back To The Top
Old 11-19-2019, 09:02 AM   #14
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

I have always had a habit of rounding to the next dollar after the pump cuts off. On my '13 Silverado, it started doing what you are talking about. Come to find out, the vent hose and canister were full of fuel and not working correctly. I started just letting the pump cut off and not adding any more. Finally the canister and hose cleared out and the problem went away.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 11-19-2019, 09:13 AM   #15
outlook8
Ten Point
 
outlook8's Avatar
 
Join Date: Apr 2008
Location: Houston
Hunt In: TX
Default

My work 2012 F250 does it too...pain in the ***. As stated, it's something to do with the evap system and can be fixed. $$$
outlook8 is offline   Reply With Quote Back To The Top
Old 11-19-2019, 09:15 AM   #16
Outdoor Man
Four Point
 
Join Date: Mar 2017
Location: Dallas
Hunt In: Central Texas
Default

Just had this problem last week. Took my Chevy Colorado in to the dealer because it was still under warranty. They called me an hour later to say they had it fixed. When I got there they showed me the end of the vent tube had a cricket in it. I got charged 30 minutes labor because insect damage is not covered under warranty. :-(
Outdoor Man is offline   Reply With Quote Back To The Top
Old 11-19-2019, 09:15 AM   #17
Mambajeep
Ten Point
 
Mambajeep's Avatar
 
Join Date: Oct 2014
Location: East Texas
Hunt In: East Texas
Default

My 17 Chevy was doing that, now I pull about 5 feet past the pump and at angle the problem went away.
Mambajeep is offline   Reply With Quote Back To The Top
Old 11-19-2019, 10:17 AM   #18
twistedmidnite
Ten Point
 
twistedmidnite's Avatar
 
Join Date: Jun 2009
Location: Gilmer, TX
Hunt In: texas
Default

Turn the nozzle upside down and rest it on the gas tank door, mine has the same problem and it'll run almost wide open if I do that.
twistedmidnite is offline   Reply With Quote Back To The Top
Old 11-19-2019, 10:30 AM   #19
Lungbustr
Pope & Young
 
Lungbustr's Avatar
 
Join Date: Jun 2007
Location: Texas
Default

Evap system problem. Probably purge valve. Could be canister if you have topped off and fuel got on there.
Lungbustr is offline   Reply With Quote Back To The Top
Old 11-19-2019, 04:18 PM   #20
Leemo
Ten Point
 
Leemo's Avatar
 
Join Date: Jun 2008
Location: Bay City, Texas
Default

Thanks for the reply’s
Leemo is offline   Reply With Quote Back To The Top
Old 11-19-2019, 04:51 PM   #21
MesquiteBean
Eight Point
 
MesquiteBean's Avatar
 
Join Date: Jul 2013
Location: Texas
Hunt In: Lavaca Co.
Default F150...fuel problem..when filling

I had an 06 F150 that did that every time Iíd fuel up.


Sent from my iPhone using Tapatalk
MesquiteBean is offline   Reply With Quote Back To The Top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1999-2012, TexasBowhunter.com