Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-23-2021, 03:07 PM   #1
Runnin4D
Four Point
 
Join Date: Dec 2018
Default 2007 Polaris Ranger 700 Issue

A ranger we usually keep at the lease, that is owned by someone else on the lease is having an issue.

Sometimes it acts like it is starving for fuel. Will run just fine and then all of the sudden this happens. Basically has a mind of its own. When it has the issue, it will stay running idle (not good but wonít die out). And when you give it throttle it will either not have enough power to move or will move but runs crappy with little power. You can keep trying and trying and eventually it will act right and run great.

This has been going on for many years, so itís not bad fuel for sure. ethanol free was ran through it all season. Have a feeling it could be a sensor or something. Wondering if anyone has had similar issues and could give advice on what to check.
Runnin4D is offline   Reply With Quote Back To The Top
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:11 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1999-2012, TexasBowhunter.com