Reply
Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Old 07-13-2019, 10:56 PM   #1
BigL
Pope & Young
 
BigL's Avatar
 
Join Date: Oct 2006
Location: Austin
Hunt In: San Saba, Burnet
Default F150 stereo not working

Last Dec it had a loud pop then stopped working. Time is flashing, direction, and temp still show up but nothing on the radio. Through the winter it would come on randomly then cut back off. Last 3 months nothing.

My heater/AC blend door actuator is also going bad so going to replace it tomorrow and to get to it I will have to pull the radio. Hoping to find something simple like a loose wire but from what I've read on line, my hopes aren't high.

We're going on a road trip in a few weeks and I'm fine taking a wireless bluetooth speaker with us and just stream music on my phone. The AC door, I don't think I can take the clicking or sometimes getting stuck so it blows hot air.

Anyone else have this problem in their F150? Mine is a 2011 with 186,000 miles.
BigL is online now   Reply With Quote Back To The Top
Old 07-13-2019, 11:01 PM   #2
oktx
Pope & Young
 
oktx's Avatar
 
Join Date: Dec 2006
Location: Wise County
Hunt In: Wise County
Default

Work pickup 2013 140000 miles. Made loud pops for a couple of months until one final pop and it’s gone. Only the temp shows now.
oktx is online now   Reply With Quote Back To The Top
Old 07-13-2019, 11:03 PM   #3
bowhunterhelm
Ten Point
 
bowhunterhelm's Avatar
 
Join Date: Oct 2006
Location: Leander
Hunt In: Leander, my back yard
Default

STart with fuses.

I just traded my 2011 F150 in, it was having a lot of issues.
bowhunterhelm is offline   Reply With Quote Back To The Top
Old 07-13-2019, 11:05 PM   #4
bowhunterhelm
Ten Point
 
bowhunterhelm's Avatar
 
Join Date: Oct 2006
Location: Leander
Hunt In: Leander, my back yard
Default

Blend motor was out on mine as well, only got heat on the driver side. Made for some tough road trips with the wife in the winter time. Lol
bowhunterhelm is offline   Reply With Quote Back To The Top
Old 07-13-2019, 11:22 PM   #5
BigL
Pope & Young
 
BigL's Avatar
 
Join Date: Oct 2006
Location: Austin
Hunt In: San Saba, Burnet
Default

Posting this video up so I can find it tomorrow morning when I'm taking the dash apart
BigL is online now   Reply With Quote Back To The Top
Old 07-14-2019, 02:21 AM   #6
pervis
Ten Point
 
Join Date: Jul 2015
Default

U can buy a stock factory radio on Ebay really cheap to replace it w
pervis is offline   Reply With Quote Back To The Top
Old 07-14-2019, 07:06 AM   #7
BigL
Pope & Young
 
BigL's Avatar
 
Join Date: Oct 2006
Location: Austin
Hunt In: San Saba, Burnet
Default

Quote:
Originally Posted by pervis View Post
U can buy a stock factory radio on Ebay really cheap to replace it w
Yea my plan is to buy a cheap replacement. Not doing that today though. Pandora + Bluetooth speak has been working fine since December. Today is all about the AC door but hoping that pulling the radio and reconnecting and making sure all wires are connected well will bring it back to life. Also going to take pics of all stickers to make sure I have what I need to replace it.
BigL is online now   Reply With Quote Back To The Top
Old 07-14-2019, 07:33 AM   #8
Pedernal
Pope & Young
 
Pedernal's Avatar
 
Join Date: Oct 2011
Location: Del Rio
Hunt In: Amistad
Default

High possibility that it's a bad solder connection somewhere in the radio if the problem was intermittent for months and then it went out completely.
Pedernal is offline   Reply With Quote Back To The Top
Old 07-14-2019, 07:37 AM   #9
sasqy
Eight Point
 
sasqy's Avatar
 
Join Date: May 2015
Location: mansfield
Hunt In: my sasquatch suit
Default

Had same problem with my 13 .
It seems to be common for sure .
Prob gotta buy a new radio !
That’s what they told me, I bought a new truck instead !
sasqy is offline   Reply With Quote Back To The Top
Old 07-14-2019, 08:25 AM   #10
pervis
Ten Point
 
Join Date: Jul 2015
Default

Make sure if u buy a new radio, a factory one on Ebay, to compare the back of your radio to the pictures of the back of the radio on Ebay. Ford made lots of the same radios w the same faces and different backs. That way your wiring harness will work. I know cause I goofed up one time and had to resell one I bought off there.
pervis is offline   Reply With Quote Back To The Top
Old 07-14-2019, 11:48 AM   #11
yaqui
Ten Point
 
yaqui's Avatar
 
Join Date: Oct 2009
Location: Dallas
Hunt In: Eastland Co.
Default

Just get a new stereo installed. Make sure it has a big screen and apple play. Wife has this in her car and it is pretty amazing.
yaqui is offline   Reply With Quote Back To The Top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:26 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1999-2012, TexasBowhunter.com