Reply
Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Old 10-17-2018, 07:56 AM   #1
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Unhappy Almost at the end of my rope.

Y'all know that about a month ago I had to get another truck. Due to financial difficulties, I had to pull money out of my 401k. Bought a 2013 Silverado that I have really been liking...... until yesterday morning. Check engine light came on. P0446. EVAP System. I'm so tired of everything going wrong. Had to peg out a credit card for a lawn mower a couple of weeks ago too. It's one thing after a frickin nother. I'm not sure how much longer I can take this ****. Sorry for the rant. This is getting old quick.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 07:59 AM   #2
abilliott
Four Point
 
Join Date: Jan 2013
Location: Carthage TX
Default

Sorry bout your troubles... mine came on this morning too...i have not a slightest clue as to what mine is though. Hope everything works out for you.
abilliott is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:01 AM   #3
Worksalot
Ten Point
 
Worksalot's Avatar
 
Join Date: Feb 2018
Location: Earth
Hunt In: The woods
Default

Makes a person wonder if the previous owner of the pickup had issues with the same problem.
Worksalot is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:02 AM   #4
Texas Tracker
Pope & Young
 
Texas Tracker's Avatar
 
Join Date: Nov 2006
Location: Wimberley Texas/Hunt every place I can!
Default

Sorry brother. This might help.
https://www.autocodes.com/p0446_chevrolet.html
Texas Tracker is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:08 AM   #5
MitchParker
Ten Point
 
MitchParker's Avatar
 
Join Date: Jan 2014
Location: Amarillo
Hunt In: Wherever I get an invite
Default

My Toyota light comes on occasionally...knowing that it has something to do with emissions and knowing that I live in a place that does not require emission tests, I simply turn the light off and go on my merry way.

Don't know if Allen is in the land of mandated passing of emissions, but if not, it's an idea.
MitchParker is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:09 AM   #6
ACbob
Six Point
 
Join Date: Jun 2013
Location: Rockport, TX
Hunt In: Sabinal & Victoria Cnty
Default

Tie a knot and hang on! Nothing lasts forever.
ACbob is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:19 AM   #7
Storm
Pope & Young
 
Storm's Avatar
 
Join Date: Nov 2010
Location: Back Home in Texas
Hunt In: Lake Whitney
Default

Could be just a loose gas cap not sealing the tank or one of the solinoides on the evap canister is bad.
Storm is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:25 AM   #8
KDinTX
Ten Point
 
KDinTX's Avatar
 
Join Date: Jun 2009
Location: Hewitt
Hunt In: Bosque Co., Henderson Co.
Default

Check gas cap first, there could also be a hose loose from the evap canister, my 09 ram did that and one of the hoses to the canister was loose. Put it back and code went away.
KDinTX is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:29 AM   #9
perow
Pope & Young
 
perow's Avatar
 
Join Date: Jul 2011
Location: Garland
Hunt In: Gordan, Moran
Default

“Tough times don’t last, Tough people do”

Let me know if you need any help
perow is online now   Reply With Quote Back To The Top
Old 10-17-2018, 08:32 AM   #10
stickemhard3
Ten Point
 
stickemhard3's Avatar
 
Join Date: Oct 2008
Location: New Waverly
Hunt In: Mont. County and Anderson County
Default

Keep fighting! I had about a 5yr stretch where nothing went well. Makes normal, non-exciting, life that much more enjoyable.
stickemhard3 is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:39 AM   #11
Grand Passage
Six Point
 
Grand Passage's Avatar
 
Join Date: Dec 2013
Location: Fair Oaks
Hunt In: Hill Country & South TX
Default

Google & youtube search the code. I seem to remember having that same code on my 2010. There is a filter box that sits on top of transmission (follow line from fuel tank area). Box can be opened and the filter media can be vacuumed. This cleared my code.

I also had a similar code due to the fuel filler breather tube becoming clogged. Have you had issues filling the gas tank? Caused by driving on too many dusty roads, also know as using a truck as a truck.

Last edited by Grand Passage; 10-17-2018 at 08:41 AM.
Grand Passage is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:53 AM   #12
mchildress
Ten Point
 
mchildress's Avatar
 
Join Date: Apr 2008
Location: Sealy,Tx
Hunt In: Polk
Default

Look at the bright side at a point there is only one direction to go and that's up. Have had a rough one this year too. Mother in law passed and two days before funeral I fall and shattered my wrist. Still have a plate and two pins that will be removed in a couple weeks but killed my bow shooting and hunting season this year. Son diagnosed with cancer and not operable at this time. Had his first round of chemo last Thursday. Keep your chin up the sun will rise tomorrow.
mchildress is online now   Reply With Quote Back To The Top
Old 10-17-2018, 09:00 AM   #13
JStrickland
Eight Point
 
JStrickland's Avatar
 
Join Date: Mar 2009
Location: Midland
Hunt In: Coleman and Mills county
Default

Give it to god he has the strength to get you through anything. Everyone goes through hard times and if it wasn’t for those hard times we would not appreciate the good times. Stay strong and lean on god and your family your never alone in anything you do.


Sent from my iPhone using Tapatalk
JStrickland is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:05 AM   #14
drop dead fred
Pope & Young
 
drop dead fred's Avatar
 
Join Date: Jan 2011
Location: Willis
Hunt In: TX, NE, MEXICO
Default

Dig your feet in took your head in and ride out the storm seasons come an go. Prayers things start turning soon for ya.
drop dead fred is online now   Reply With Quote Back To The Top
Old 10-17-2018, 09:13 AM   #15
HDWRENCH
Ten Point
 
HDWRENCH's Avatar
 
Join Date: Sep 2015
Location: Keller
Hunt In: Cisco, San Juan
Default

SO evap is gas cap or pump or filter . or you have a hole in a line . the system is nothing special all if does is suck vapors from the fuel in a charcoal canister . gas cap must hold vacuum as well . In your inspection they test the cap only , but its not the end of the world .

But since that is an emission item it may be covered for 8/80 or 10/100 dealers will not tell you this but it may be still under factory warranty . here is the kit its not a huge cost , leaving the fuel cap loose will trigger it as well as the unit never sees the tank going under vacuum

https://www.partsgeek.com/zzt2k61-gm...ter+Vent+Valve
HDWRENCH is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:30 AM   #16
BowhunterB
Eight Point
 
Join Date: Jul 2011
Location: San Antonio
Hunt In: Hill Country and Searching
Default

Hang in there man, I am sure something good is waiting around the corner for you. Stay strong and keep the faith, praying things turn for you!
BowhunterB is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:32 AM   #17
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by MitchParker View Post
My Toyota light comes on occasionally...knowing that it has something to do with emissions and knowing that I live in a place that does not require emission tests, I simply turn the light off and go on my merry way.

Don't know if Allen is in the land of mandated passing of emissions, but if not, it's an idea.
Yep. Emission county.
Quote:
Originally Posted by Storm View Post
Could be just a loose gas cap not sealing the tank or one of the solinoides on the evap canister is bad.
Quote:
Originally Posted by KDinTX View Post
Check gas cap first, there could also be a hose loose from the evap canister, my 09 ram did that and one of the hoses to the canister was loose. Put it back and code went away.
Put a new cap on it yesterday. No change.

Quote:
Originally Posted by perow View Post
“Tough times don’t last, Tough people do”

Let me know if you need any help
You've already done enough for us Spencer.
Quote:
Originally Posted by stickemhard3 View Post
Keep fighting! I had about a 5yr stretch where nothing went well. Makes normal, non-exciting, life that much more enjoyable.
Our stretch has been going on for 10yrs and doesn't seem to be slowing down.
Quote:
Originally Posted by Grand Passage View Post
Google & youtube search the code. I seem to remember having that same code on my 2010. There is a filter box that sits on top of transmission (follow line from fuel tank area). Box can be opened and the filter media can be vacuumed. This cleared my code.

I also had a similar code due to the fuel filler breather tube becoming clogged. Have you had issues filling the gas tank? Caused by driving on too many dusty roads, also know as using a truck as a truck.
I have noticed that I have to fill it slower.
Quote:
Originally Posted by mchildress View Post
Look at the bright side at a point there is only one direction to go and that's up. Have had a rough one this year too. Mother in law passed and two days before funeral I fall and shattered my wrist. Still have a plate and two pins that will be removed in a couple weeks but killed my bow shooting and hunting season this year. Son diagnosed with cancer and not operable at this time. Had his first round of chemo last Thursday. Keep your chin up the sun will rise tomorrow.
My prayers are with you and your family.
Quote:
Originally Posted by JStrickland View Post
Give it to god he has the strength to get you through anything. Everyone goes through hard times and if it wasn’t for those hard times we would not appreciate the good times. Stay strong and lean on god and your family your never alone in anything you do.


Sent from my iPhone using Tapatalk
I'm beginning to have my doubts.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:34 AM   #18
WCB
Pope & Young
 
WCB's Avatar
 
Join Date: Oct 2006
Location: Dallas
Hunt In: Wise/Montague/Grayson
Default

Quote:
Originally Posted by perow View Post
“Tough times don’t last, Tough people do”

Let me know if you need any help
What he said Randy!!

If I can help you fix it this weekend let me know. I can hunt the next one!!
WCB is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:37 AM   #19
denimdeerslayer
Pope & Young
 
denimdeerslayer's Avatar
 
Join Date: Jun 2007
Location: Hempstead
Hunt In: Waller
Default

And thats why my next ride hopefully doesnt even have a computer.
denimdeerslayer is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:45 AM   #20
boh347
Pope & Young
 
boh347's Avatar
 
Join Date: Sep 2010
Location: Knickerbocker, Texas
Hunt In: coke county, tx Nolan county, tx
Default

Keep your head up bud things will get better.
boh347 is online now   Reply With Quote Back To The Top
Old 10-17-2018, 10:11 AM   #21
KyleW
Eight Point
 
Join Date: Sep 2017
Location: Allen TX
Hunt In: Gordon TX
Default

If a code was going to come on my truck I would rather it be evap than anything else.
Maybe try resetting the code and seeing if it triggers again. Car should not be up for inspection anytime soon if you just bought it. I say reset it and see because two years ago, was towing a trailer and got an engine light that came up evap. reset the code and didn’t change anything (not even the gas cap) and to date the light hasn’t come back on.
KyleW is offline   Reply With Quote Back To The Top
Old 10-17-2018, 10:20 AM   #22
Grand Passage
Six Point
 
Grand Passage's Avatar
 
Join Date: Dec 2013
Location: Fair Oaks
Hunt In: Hill Country & South TX
Default

Quote:
Originally Posted by Grand Passage View Post
Google & youtube search the code. I seem to remember having that same code on my 2010. There is a filter box that sits on top of transmission (follow line from fuel tank area). Box can be opened and the filter media can be vacuumed. This cleared my code.

I also had a similar code due to the fuel filler breather tube becoming clogged. Have you had issues filling the gas tank? Caused by driving on too many dusty roads, also know as using a truck as a truck.
The piece on the left is what you are looking for above the transmission. Pry off the cover and clean the filter media. It is definitely worth 20 minutes attempting this.



The next thing i would try would be cleaning the charcoal canister, and there are plenty of youtube videos on how to perform this.
Grand Passage is offline   Reply With Quote Back To The Top
Old 10-17-2018, 10:27 AM   #23
Traildust
Pope & Young
 
Traildust's Avatar
 
Join Date: Apr 2007
Location: Alvin, Texas
Hunt In: Looking!
Default

Take to a repair shop that has a real diagnostic computer. They can pinpoint exactly what the issue is. Best $75 you'll spend.

It'll all work out.....You got a year before you need an inspection!

We told you not to by a GM
Traildust is online now   Reply With Quote Back To The Top
Old 10-17-2018, 10:40 AM   #24
miket
Pope & Young
 
miket's Avatar
 
Join Date: Oct 2008
Location: Plantersville
Hunt In: Grimes County, Victoria
Default

Dang man, hate that its going so rough! Good news is, like others have said, that code is generally minor. Seems like the solenoid for my wifes tahoe was like $15
miket is offline   Reply With Quote Back To The Top
Old 10-17-2018, 10:44 AM   #25
Eric Pence
Pope & Young
 
Eric Pence's Avatar
 
Join Date: Jun 2008
Location: Bedford
Hunt In: Roosevelt/Sonora
Default

Quote:
Originally Posted by mchildress View Post
Look at the bright side at a point there is only one direction to go and that's up. Have had a rough one this year too. Mother in law passed and two days before funeral I fall and shattered my wrist. Still have a plate and two pins that will be removed in a couple weeks but killed my bow shooting and hunting season this year. Son diagnosed with cancer and not operable at this time. Had his first round of chemo last Thursday. Keep your chin up the sun will rise tomorrow.
Prayers for your son Mchildress..Just went thru my 3rd round of Chemo if yall have any questions about side-effects PM me (I have about 6 that stay with me at all times and took forever to figure them out.)

And Prayers for you Randy..Its all small problems in the Big Picture of life, how is you Grandchild ?

Last edited by Eric Pence; 10-17-2018 at 10:46 AM.
Eric Pence is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:09 AM   #26
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by Eric Pence View Post
Prayers for your son Mchildress..Just went thru my 3rd round of Chemo if yall have any questions about side-effects PM me (I have about 6 that stay with me at all times and took forever to figure them out.)

And Prayers for you Randy..Its all small problems in the Big Picture of life, how is you Grandchild ?
I've been praying hard for you Eric. I know there are worse things than what I'm going through. Alexis is doing fine. Thanks for asking.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:14 AM   #27
Eric Pence
Pope & Young
 
Eric Pence's Avatar
 
Join Date: Jun 2008
Location: Bedford
Hunt In: Roosevelt/Sonora
Default

Quote:
Originally Posted by Goldeneagle View Post
I've been praying hard for you Eric. I know there are worse things than what I'm going through. Alexis is doing fine. Thanks for asking.
Keep Your Head Up Randy ..We all love you here, this place wouldn't be the same without People like you..If you ever need help I am always around cant work like I used to but I could hand you some tools or keep you laughing while you work.
Eric Pence is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:20 AM   #28
stickbowcoop
Ten Point
 
stickbowcoop's Avatar
 
Join Date: Feb 2017
Location: Springtown TX
Hunt In: OH, PA, looking for a place in TX.
Default

Sorry to read that Goldeneagle. It can always get worse, but I know what it feels like for things to pile on. And vehicle issues, to me, can be the very frustrating. Especially in your case where you bough newer truck to avoid this. With my 2001 Silverado it was because I wasn't clicking the cap enough when closing it. Sounds ridiculous but my CIL would come in if it only clicked it once vs 3 when closing it. I think that was the number, that was 3 years ago now and all the medical issues I have been dealing with have messed with my concentration. Stress does that so I definitely commiserate with you.
stickbowcoop is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:24 AM   #29
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by Eric Pence View Post
Keep Your Head Up Randy ..We all love you here, this place wouldn't be the same without People like you..If you ever need help I am always around cant work like I used to but I could hand you some tools or keep you laughing while you work.
Thanks for the offer, but you take care of yourself. Your a good man and we don't want to lose you. This stupid weather doesn't help. It's already got me in a blah mood to begin with.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:27 AM   #30
Smart
Pope & Young
 
Smart's Avatar
 
Join Date: Oct 2006
Location: Denton, TX
Hunt In: Tom Green County
Default

I'll bring the Burger King!
Smart is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:31 AM   #31
BowSlayer
Pope & Young
 
BowSlayer's Avatar
 
Join Date: Aug 2011
Location: Troup
Hunt In: Smith and Sutton County
Default

I know you said you put a gas cap on and the light is still on but usually you have to start the truck X number of times before the light resets. Go by autozone and have them clear the code and see if it comes back.
BowSlayer is offline   Reply With Quote Back To The Top
Old 10-17-2018, 11:33 AM   #32
deerplanter
Ten Point
 
deerplanter's Avatar
 
Join Date: Nov 2007
Location: Beach City
Default

Going thru the same code with my step daughters car. I changed the control valve and gas cap. That seemed to fix the EVAP issue but then she had a turbo issue that Chevy fixed, said a bad fuse. We will see, that was yesterday.
deerplanter is online now   Reply With Quote Back To The Top
Old 10-17-2018, 11:36 AM   #33
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by Smart View Post
I'll bring the Burger King!
Thanks for the kind gesture but............................. NO!
Quote:
Originally Posted by BowSlayer View Post
I know you said you put a gas cap on and the light is still on but usually you have to start the truck X number of times before the light resets. Go by autozone and have them clear the code and see if it comes back.
I just thought about this a little bit ago. I have a code reader and will clear it when I get home and see what happens.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 01:19 PM   #34
BigThicketBoy
Pope & Young
 
BigThicketBoy's Avatar
 
Join Date: Aug 2011
Location: Barbers Hill Tx
Hunt In: Hardin Co
Default

I could tell ya things that would make you cry.
Just hammer on .
This to shall pass

Sent from my LM-X210CMR using Tapatalk
BigThicketBoy is offline   Reply With Quote Back To The Top
Old 10-17-2018, 01:35 PM   #35
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by BigThicketBoy View Post
I could tell ya things that would make you cry.
Just hammer on .
This to shall pass

Sent from my LM-X210CMR using Tapatalk
I'm not so sure about that. I've been through way more than y'all know about.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 01:37 PM   #36
curtintex
Pope & Young
 
curtintex's Avatar
 
Join Date: Oct 2009
Location: Porter, TX
Hunt In: Trinity County
Default

Quote:
Originally Posted by Goldeneagle View Post
I'm not so sure about that. I've been through way more than y'all know about.
I'm sorry you're dealing with this stuff. It happens to us all sooner or later and from time to time. Life is tough. It is hard. You'll be in my prayers.
curtintex is offline   Reply With Quote Back To The Top
Old 10-17-2018, 01:43 PM   #37
TheHammer
Ten Point
 
TheHammer's Avatar
 
Join Date: Jul 2012
Location: Carthage, TX
Hunt In: Tom Green Co, Panola Co, TX
Default



Life is tough man, but it’s all you can do. I’ll be praying for you


Sent from my iPhone using Tapatalk
TheHammer is offline   Reply With Quote Back To The Top
Old 10-17-2018, 01:49 PM   #38
mooney_ag
Eight Point
 
Join Date: Oct 2014
Location: Aledo
Hunt In: Erath County
Default

I have an 07 Tahoe. Same code popped up two weeks ago. I was able to clean the filter that was caked with dirt/mud from the rains at the first of the month after driving 60 miles on rain soaked caliche. Cleared the code and 600 miles later still good. Your pick up is a little different evaporate system/location. I'd try cleaning the filter and resetting the code. Replacing that it would run about 150 for parts.
mooney_ag is online now   Reply With Quote Back To The Top
Old 10-17-2018, 01:50 PM   #39
Strummer
Pope & Young
 
Strummer's Avatar
 
Join Date: Oct 2006
Location: Edna Tx
Hunt In: At Gary's place ,and the backyard
Default

I know the feeling . I’m going on 4 bad years . Crap needs to change pretty soon .
Strummer is offline   Reply With Quote Back To The Top
Old 10-17-2018, 01:54 PM   #40
Worksalot
Ten Point
 
Worksalot's Avatar
 
Join Date: Feb 2018
Location: Earth
Hunt In: The woods
Default

Randy, as you probably know, I’ve had baggage too from difficult situations. Just the way things are as others have said. Your circumstances don’t have to define you. Things will get better.
Worksalot is offline   Reply With Quote Back To The Top
Old 10-17-2018, 02:11 PM   #41
Hooverfb
Eight Point
 
Hooverfb's Avatar
 
Join Date: Jan 2017
Default

As others have said, evap isn't a huge issue... most of the time the problem with it is it's hard to nail down cause. One thing, if you clear code, run it about 20-50 miles before inspection, all the other tests should complete and should be able to pass emissions with one test reading NA.
Praying for you.
Hooverfb is offline   Reply With Quote Back To The Top
Old 10-17-2018, 03:16 PM   #42
SaltwaterSlick
Pope & Young
 
SaltwaterSlick's Avatar
 
Join Date: Oct 2006
Default

My ranch truck(06 Silverado) had the same issue... I watched the You Tube videos and cleaned the filter, washed out the Charcoal canister and put 'er all back together and she's been purrin' like a kitten since... MUCH easier to fill up with gas too! Other thing I found out was trying to "top off" you tank can mess this vacuum system up too as it can dump gas into that carbon filter canister and mess up the solenoid so I don't do that anymore. You hang in there! We don't need no GOF's to go flippin' out on us! We gotta stick togeher!
SaltwaterSlick is offline   Reply With Quote Back To The Top
Old 10-17-2018, 04:52 PM   #43
Lungbustr
Pope & Young
 
Lungbustr's Avatar
 
Join Date: Jun 2007
Location: Texas
Default

Quote:
Originally Posted by SaltwaterSlick View Post
My ranch truck(06 Silverado) had the same issue... I watched the You Tube videos and cleaned the filter, washed out the Charcoal canister and put 'er all back together and she's been purrin' like a kitten since... MUCH easier to fill up with gas too! Other thing I found out was trying to "top off" you tank can mess this vacuum system up too as it can dump gas into that carbon filter canister and mess up the solenoid so I don't do that anymore. You hang in there! We don't need no GOF's to go flippin' out on us! We gotta stick togeher!

Solid advice, I did several solenoids on different fords before we realized we could be part of the problem by topping off.

My work car would make you lose your mind trying to fill up. It would only take a trickle of gas without shutting off pump.
Lungbustr is offline   Reply With Quote Back To The Top
Old 10-17-2018, 05:07 PM   #44
Grand Passage
Six Point
 
Grand Passage's Avatar
 
Join Date: Dec 2013
Location: Fair Oaks
Hunt In: Hill Country & South TX
Default

Quote:
Originally Posted by SaltwaterSlick View Post
My ranch truck(06 Silverado) had the same issue... I watched the You Tube videos and cleaned the filter, washed out the Charcoal canister and put 'er all back together and she's been purrin' like a kitten since... MUCH easier to fill up with gas too! Other thing I found out was trying to "top off" you tank can mess this vacuum system up too as it can dump gas into that carbon filter canister and mess up the solenoid so I don't do that anymore. You hang in there! We don't need no GOF's to go flippin' out on us! We gotta stick togeher!
Agree on this advice. I never did it on my truck, and still had issues though.
Grand Passage is offline   Reply With Quote Back To The Top
Old 10-17-2018, 06:39 PM   #45
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by SaltwaterSlick View Post
My ranch truck(06 Silverado) had the same issue... I watched the You Tube videos and cleaned the filter, washed out the Charcoal canister and put 'er all back together and she's been purrin' like a kitten since... MUCH easier to fill up with gas too! Other thing I found out was trying to "top off" you tank can mess this vacuum system up too as it can dump gas into that carbon filter canister and mess up the solenoid so I don't do that anymore. You hang in there! We don't need no GOF's to go flippin' out on us! We gotta stick togeher!
Yeah, I've always rounded the pump up to the next dollar. I'm thinking this truck doesn't like that. I'm just just waiting on the weather so I can work on it.
Goldeneagle is offline   Reply With Quote Back To The Top
Old 10-17-2018, 06:52 PM   #46
M16
Pope & Young
 
M16's Avatar
 
Join Date: Dec 2009
Hunt In: Colorado, LaSalle, ,Menard Counties
Default

My check engine light came on in my daily driver a couple of years ago. A two inch piece of electrical tape fixed it.
M16 is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:30 PM   #47
ultralite09
Pope & Young
 
ultralite09's Avatar
 
Join Date: Jan 2012
Location: N. DFW
Hunt In: Childress, Brady
Default

Keep your head up Randy! You're tough as nails and you know you have plenty of us on here for help with anything! Holler if I can help out
ultralite09 is offline   Reply With Quote Back To The Top
Old 10-17-2018, 08:56 PM   #48
Paycheck
Six Point
 
Paycheck's Avatar
 
Join Date: May 2015
Location: Waco
Default

I feel you my light just came on today and I just spent $1500 on it 2 weeks ago. Its a 2014 silverado
Paycheck is offline   Reply With Quote Back To The Top
Old 10-17-2018, 09:16 PM   #49
Acameron52
Ten Point
 
Acameron52's Avatar
 
Join Date: Jun 2014
Location: Lewisville
Hunt In: Coleman
Default

Well... it can only get better.
Acameron52 is offline   Reply With Quote Back To The Top
Old 10-17-2018, 10:40 PM   #50
LWC
Ten Point
 
Join Date: Oct 2010
Default

My 03 Silverado would have that same code come on, when the weather got cool. Weather
would warm up and it would go away. Was hard to figure exactly what caused it, but it didn't affect performance. You might clear the code if you need to pass inspection. But don't sweat it too much. Hang in there
LWC is online now   Reply With Quote Back To The Top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1999-2012, TexasBowhunter.com