Reply
Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Old 08-05-2019, 12:31 PM   #1
warrington
Ten Point
 
Join Date: Jan 2007
Location: Heath, TX
Hunt In: Abilene
Default Rain bird sprinkler controller not working

Any idea why my two-year-old Rainbird sprinkler system stopped working this past week.Nothing on the display nor any lights on the panel. Never had a problem with it. The breaker did not kick off. I plugged it into another plug that I knew was hot, and that did not help. I opened up the box and the tether strap is plugged in. Ill turn the knob all around and nothing kicks on. Tried manual watering nothing. Is there a fuse that could have gone out
warrington is offline   Reply With Quote Back To The Top
Old 08-05-2019, 12:34 PM   #2
Antlers86
Associate Sponsor
 
Antlers86's Avatar
 
Join Date: Oct 2011
Location: Athens
Hunt In: Jack/Coleman/Henderson
Default

All I can say is RainBird sucks. Never had any luck with them. Hunter has always been good to me.
Antlers86 is offline   Reply With Quote Back To The Top
Old 08-05-2019, 12:35 PM   #3
Johnny Dangerr
Pope & Young
 
Johnny Dangerr's Avatar
 
Join Date: Dec 2009
Location: Houston
Hunt In: Mainly Guide Now
Default

I replace mine every 6 years or so......
Johnny Dangerr is online now   Reply With Quote Back To The Top
Old 08-05-2019, 12:36 PM   #4
rudedog47
Four Point
 
rudedog47's Avatar
 
Join Date: May 2007
Location: Lindale, TX
Hunt In: Menard County
Default

check for a blown fuse.....in the sprinkler unit
rudedog47 is offline   Reply With Quote Back To The Top
Old 08-05-2019, 12:47 PM   #5
warrington
Ten Point
 
Join Date: Jan 2007
Location: Heath, TX
Hunt In: Abilene
Default

I looked and didn’t see one
warrington is offline   Reply With Quote Back To The Top
Old 08-05-2019, 12:57 PM   #6
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

I just replaced a one year old Rainbird about two months ago. I switched to Orbit.
Goldeneagle is online now   Reply With Quote Back To The Top
Old 08-05-2019, 12:58 PM   #7
quarterback
Pope & Young
 
quarterback's Avatar
 
Join Date: Oct 2007
Location: Sunnyvale
Hunt In: San Saba
Default

Having the same problem with a Rainbird system at my office. So there's a fuse in it somewhere?
quarterback is offline   Reply With Quote Back To The Top
Old 08-05-2019, 01:02 PM   #8
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by quarterback View Post
Having the same problem with a Rainbird system at my office. So there's a fuse in it somewhere?
Yes, there should be a fuse. Mine was just a POS. Wouldn't keep time worth a crap and it would turn on stations at all kinds of weird hours when it was in the OFF position.
Goldeneagle is online now   Reply With Quote Back To The Top
Old 08-05-2019, 01:03 PM   #9
dvinson
Four Point
 
dvinson's Avatar
 
Join Date: Oct 2006
Location: Henderson, Tx
Default

THE display is out, I know it's frustrating that products are that crappy, but that's the way it is now. I use hunter controllers, but it can happen with any brand. The old mechanical controllers from 30 or 40 years ago lasted WAY longer. I unplug my controller after the summer, just for that reason, to hopefully extend life of display or any other electronics in it.
dvinson is offline   Reply With Quote Back To The Top
Old 08-05-2019, 01:04 PM   #10
Smart
Pope & Young
 
Smart's Avatar
 
Join Date: Oct 2006
Location: Denton, TX
Hunt In: Tom Green County
Default

Man yall are making me nervous.....Yall are telling me my 20 year old Rainbird might quit on me?..
Smart is offline   Reply With Quote Back To The Top
Old 08-05-2019, 01:05 PM   #11
Goldeneagle
Pope & Young
 
Goldeneagle's Avatar
 
Join Date: Oct 2006
Location: Allen, TX
Hunt In: Where ever I get a chance.
Default

Quote:
Originally Posted by Smart View Post
Man yall are making me nervous.....Yall are telling me my 20 year old Rainbird might quit on me?..
That was back when things were made worth a crap.
Goldeneagle is online now   Reply With Quote Back To The Top
Old 08-05-2019, 01:30 PM   #12
Rubberdown
Ten Point
 
Join Date: May 2015
Location: Houston
Default

Did you take a volt meter and cverify that the dc power supply is still good? If so... time for a new controller.
Rubberdown is offline   Reply With Quote Back To The Top
Old 08-05-2019, 01:37 PM   #13
Reedimus
Eight Point
 
Reedimus's Avatar
 
Join Date: Aug 2013
Location: Helotes
Hunt In: Bandera County, Bee County
Default

Might be the transformer in it
Reedimus is offline   Reply With Quote Back To The Top
Old 08-05-2019, 01:39 PM   #14
rferg84
Pope & Young
 
rferg84's Avatar
 
Join Date: Mar 2010
Location: Sweetwater TX
Hunt In: Nolan and Fisher Counties
Default

Quote:
Originally Posted by Antlers86 View Post
All I can say is RainBird sucks. Never had any luck with them. Hunter has always been good to me.
Everyone says that, I've read reviews but we've never had an issue with the that part of the system. Now it's like a ground comes loose or a head breaks every week.
rferg84 is offline   Reply With Quote Back To The Top
Old 08-05-2019, 01:57 PM   #15
Codypatt1
Ten Point
 
Codypatt1's Avatar
 
Join Date: Mar 2007
Location: Terrell / Poetry
Hunt In: SE OK
Default

Good time to upgrade to a Rachio !
Codypatt1 is offline   Reply With Quote Back To The Top
Old 08-05-2019, 02:17 PM   #16
Rush2Judge
Ten Point
 
Rush2Judge's Avatar
 
Join Date: Jul 2014
Location: Plano
Hunt In: Wood County
Default

Before throwing it out, I would check the transformer. Everyone uses cheap, Chinese sources for these things. Which makes it a cheap, easy fix.
Rush2Judge is offline   Reply With Quote Back To The Top
Old 08-05-2019, 02:27 PM   #17
Outback
Ten Point
 
Outback's Avatar
 
Join Date: Oct 2006
Location: Pearland
Hunt In: Llano primarily
Default

Mine has a battery that I have to replace. I do this every 2-3 years.
Outback is offline   Reply With Quote Back To The Top
Old 08-05-2019, 02:40 PM   #18
RR 314
Ten Point
 
Join Date: Nov 2006
Default

Does it have a reset button that is visible when you remove the cover? Mine has a reset button when the cover is removed.
RR 314 is online now   Reply With Quote Back To The Top
Old 08-05-2019, 02:51 PM   #19
warrington
Ten Point
 
Join Date: Jan 2007
Location: Heath, TX
Hunt In: Abilene
Default



This is the unit


Sent from my iPhone using Tapatalk
warrington is offline   Reply With Quote Back To The Top
Old 08-05-2019, 02:56 PM   #20
warrington
Ten Point
 
Join Date: Jan 2007
Location: Heath, TX
Hunt In: Abilene
Default




Sent from my iPhone using Tapatalk
warrington is offline   Reply With Quote Back To The Top
Old 08-05-2019, 03:45 PM   #21
rtarcher
Ten Point
 
rtarcher's Avatar
 
Join Date: Oct 2006
Location: San Antonio
Hunt In: Atascosa County
Default

Certainly check output from the plug in transformer. Also, That last picture looks like a battery compartment of some sort. Those would be the cheapest fixes, if they are bad, as stated above.

Todd
rtarcher is offline   Reply With Quote Back To The Top
Old 08-05-2019, 05:46 PM   #22
32drawlength
Pope & Young
 
32drawlength's Avatar
 
Join Date: Oct 2011
Location: Frisco
Hunt In: Palo Pinto County, Mexia
Default

Crap my Rainbird quit this past weekend. Checked fuse & transformer, maybe a Solenoid
32drawlength is offline   Reply With Quote Back To The Top
Old 08-05-2019, 06:25 PM   #23
Rubberdown
Ten Point
 
Join Date: May 2015
Location: Houston
Default

Did. You. Check. The. Power. Supply. With. A. Volt. Meter.
Rubberdown is offline   Reply With Quote Back To The Top
Old 08-05-2019, 08:30 PM   #24
32drawlength
Pope & Young
 
32drawlength's Avatar
 
Join Date: Oct 2011
Location: Frisco
Hunt In: Palo Pinto County, Mexia
Default

Not hijacking this thread but yes I checked the transformer, the fuse...all good
looks like the motherboard may have a burnt out circuit on the backside
32drawlength is offline   Reply With Quote Back To The Top
Old 08-05-2019, 08:37 PM   #25
rklazajr
Four Point
 
rklazajr's Avatar
 
Join Date: May 2016
Default

Had a 13 yo hunter unit go out this summer. Replaced it with the same one for$90 on Amazon. Back to normal

Sent from my ONEPLUS A6013 using Tapatalk
rklazajr is online now   Reply With Quote Back To The Top
Old 08-06-2019, 08:57 PM   #26
32drawlength
Pope & Young
 
32drawlength's Avatar
 
Join Date: Oct 2011
Location: Frisco
Hunt In: Palo Pinto County, Mexia
Default

Went to Lowes tonight & spent $32 on a new unit, its working again
32drawlength is offline   Reply With Quote Back To The Top
Old 08-06-2019, 09:09 PM   #27
Humper
Pope & Young
 
Humper's Avatar
 
Join Date: Oct 2006
Location: Corinth
Hunt In: Tom Green Co.
Default

For the op.....

https://ww3.rainbird.com/documents/d...otingGuide.pdf
Humper is offline   Reply With Quote Back To The Top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1999-2012, TexasBowhunter.com