Reply
Go Back   TexasBowhunter.com Community Discussion Forums > Topics > Around the Campfire
 
Thread Tools Display Modes
Old 10-12-2017, 10:01 PM   #1
red-fin
Six Point
 
red-fin's Avatar
 
Join Date: Dec 2008
Location: Temple, Texas
Hunt In: Duval, Concho Counties
Default Master built smoker

Anyone have bad experience with these? I am on my second one in a year. After the first went electrical crazy the sent me another and now this one seemed to be doing same thing? When they work they are awesome.
red-fin is offline   Reply With Quote Back To The Top
Old 10-12-2017, 10:40 PM   #2
Z7X
Ten Point
 
Z7X's Avatar
 
Join Date: Aug 2011
Location: Denton, Texas
Hunt In: Forestburg
Default

I love mine. Works great.
Z7X is offline   Reply With Quote Back To The Top
Old 10-13-2017, 07:00 AM   #3
Uncle Saggy
Pope & Young
 
Uncle Saggy's Avatar
 
Join Date: May 2009
Default

I've had 2 over the years, never had a problem


Sent from my iPad using Tapatalk
Uncle Saggy is offline   Reply With Quote Back To The Top
Old 10-13-2017, 07:01 AM   #4
Brett A
Ten Point
 
Brett A's Avatar
 
Join Date: Jul 2008
Location: Denton County
Hunt In: McCulloch and Grayson
Default

Knock on wood....
Mine has been working great for over three years now.
Brett A is offline   Reply With Quote Back To The Top
Old 10-13-2017, 09:27 AM   #5
RascalArms
Pope & Young
 
RascalArms's Avatar
 
Join Date: Mar 2013
Location: Forney, TX
Hunt In: Schleicher County
Default

I love mine...it has worked great so far. The remote went out and they sent me a brand new one free.
RascalArms is offline   Reply With Quote Back To The Top
Old 10-13-2017, 10:26 AM   #6
Bowhica
Ten Point
 
Bowhica's Avatar
 
Join Date: Apr 2007
Location: Richmond, Texas
Hunt In: Llano-ish
Default

Got mine one year ago. Love it. Its the 40 with bluetooth.
Bowhica is offline   Reply With Quote Back To The Top
Old 10-13-2017, 10:36 AM   #7
CJMO74
Nubbin' Buck
 
Join Date: Sep 2017
Default

Great unit! Only thing is it is very hard to get crust on your smoked meats.
CJMO74 is offline   Reply With Quote Back To The Top
Old 10-13-2017, 10:51 AM   #8
JonBoy
Ten Point
 
JonBoy's Avatar
 
Join Date: Aug 2008
Location: San Antonio, TX
Hunt In: Mason, TX; Doss, TX
Default

Mine (Model 20070910) worked great for about 6 months and then I noticed for some reason when the chamber got up to temp it would quit smoking. Fussed with it a while and never could get it working right. After Googling I found that some models have controller problems that experience this very issue (turns off smoker heating element when it gets to temp and never turns it back on) and it would require replacement. I instead bought the offset cold smoking attachment and I run that at the same time as the regular chamber to hot smoke or turn the main chamber off to cold smoke.

Last edited by JonBoy; 10-13-2017 at 11:04 AM..
JonBoy is offline   Reply With Quote Back To The Top
Old 10-13-2017, 12:59 PM   #9
double bogey
Eight Point
 
Join Date: Oct 2015
Location: Mesquite
Hunt In: where ever I can
Default

I have had the controller fail twice on mine. I will build a pid controller to fix this at some point. My fault, don't leave the smoker out in the rain without a cover.

You need an Amazing Pellet Smoker to make smoke with the electric smokers. The tray that comes with it doesn't make enough smoke to get the smoke ring right.
double bogey is offline   Reply With Quote Back To The Top
Old 10-13-2017, 01:02 PM   #10
db@100
Eight Point
 
db@100's Avatar
 
Join Date: Sep 2009
Default

Did the controller area get wet?
db@100 is offline   Reply With Quote Back To The Top
Old 10-13-2017, 01:22 PM   #11
Hix
Ten Point
 
Hix's Avatar
 
Join Date: Sep 2015
Location: North Longview
Hunt In: East Texas- Gregg Co. & Marion Co.
Default

No problems. I keep mine under my porch with the cover over it
Hix is offline   Reply With Quote Back To The Top
Old 10-13-2017, 01:59 PM   #12
red-fin
Six Point
 
red-fin's Avatar
 
Join Date: Dec 2008
Location: Temple, Texas
Hunt In: Duval, Concho Counties
Default

It's in shop when not used. Then under big porch. Never has been wet. Called them today. They said heating element. Sending me one. We will see.
red-fin is offline   Reply With Quote Back To The Top
Old 10-13-2017, 03:08 PM   #13
red-fin
Six Point
 
red-fin's Avatar
 
Join Date: Dec 2008
Location: Temple, Texas
Hunt In: Duval, Concho Counties
Default

It's in shop when not used. Then under big porch. Never has been wet. Called them today. They said heating element. Sending me one. We will see.
red-fin is offline   Reply With Quote Back To The Top
Old 10-13-2017, 03:20 PM   #14
Tx_Wader
Ten Point
 
Tx_Wader's Avatar
 
Join Date: Sep 2007
Location: El Campo
Hunt In: Jackson County and Utopia
Default

I have the 40" with glass window, digital controls and remote. Never a problem with it and we used it a lot.

The temperature probe stopped working and I haven't messed with it but that's the only problem I have had.
Tx_Wader is offline   Reply With Quote Back To The Top
Old 10-13-2017, 03:39 PM   #15
dc1986
Pope & Young
 
dc1986's Avatar
 
Join Date: Oct 2006
Location: Lumberton,Texas
Hunt In: Mexico
Default

Quote:
Originally Posted by red-fin View Post
It's in shop when not used. Then under big porch. Never has been wet. Called them today. They said heating element. Sending me one. We will see.
Had one for a few years and the heating element went out. Turns out it was my fault for overfilling the wood tray. Installed a new element, followed the wood loading directions, and no more problems- until Harvey.
dc1986 is offline   Reply With Quote Back To The Top
Old 10-13-2017, 03:48 PM   #16
oktx
Pope & Young
 
oktx's Avatar
 
Join Date: Dec 2006
Location: Wise County
Hunt In: Wise County
Default

Mine is about 3 years old and has worked fine until the last 2 smokes. I set it on 240 it runs up to 265+ then down to 210 and then back up and it does this for the entire time. I guess I may need a new controller.
oktx is offline   Reply With Quote Back To The Top
Old 10-13-2017, 10:26 PM   #17
double bogey
Eight Point
 
Join Date: Oct 2015
Location: Mesquite
Hunt In: where ever I can
Default

Mine both got wet and failed. Last one charred a brisket I left in it overnight. put it in at 10, rained a bit, at 6 when i got up I had a lump of charcoal. 50 swing is pretty normal with these controls. That's why I want to build a pid control. Mine on my lead pot keeps it within a couple of degrees while making boolits.
double bogey is offline   Reply With Quote Back To The Top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2012, TexasBowhunter.com