View Single Post
Old 11-14-2017, 11:20 AM   #8
Diamond S
Ten Point
 
Diamond S's Avatar
 
Join Date: Oct 2006
Location: Caldwell, Texas
Default

OK, so here is what I just found out that cleared up a lot of things, as well as appears to have fixed the problem.

I stated the compressor was charged, it was, but I can't tell you the exact PSI because I was using one of the things you buy from Wal-Mart. So I go out fire up the truck turn on the A/C and it" looks" as if the clutch engages, still warm air. So I dig a little deeper and check voltage at the compressor...got it. So now I am thinking bad clutch. I kill the truck and I am going to check the clutch for play and just do a general check to see if anything is obviously wrong. The clutch fell off in my hand!!! The noise I was hearing was the clutch not being tight so when it would try in engage it was slipping. Well the bolt was nowhere to be found, so I scrounged up a bolt that I had to cut off 3 times to make it short enough to not bottom out before it got tight. Got it on and tight and fired up the truck, within 30 seconds I have cold air blowing in my truck. Just think, this certified mechanic missed all of that! Now my concern is 1. did he know the problem and was just trying to make a buck, 2. did he really just miss it? I mean I found it in 5 minutes and I know next to nothing about an A/C and I am far from being a mechanic. 3. Is this a common practice in dealerships?

Thanks to everyone who responded.
Diamond S is offline   Reply With Quote Back To The Top